Network issues in some regions
Incident Report for FAX.PLUS
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 11:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2021 - 11:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 10, 2021 - 07:03 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Nov 10, 2021 - 06:06 UTC
This incident affected: Website (Home Page) and Applications (Web App, iOS App, Android App, Email to Fax, G Suite Add-on, Microsoft Word Add-in, Slack App, Zapier Integration).