Degraded performance issue in some regions
Incident Report for FAX.PLUS
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 15:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2021 - 15:48 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 24, 2021 - 15:35 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 24, 2021 - 15:25 UTC
Investigating
We are currently investigating this issue.
Posted Sep 24, 2021 - 14:40 UTC
This incident affected: Applications (Web App, iOS App, Android App, Email to Fax, G Suite Add-on, Microsoft Word Add-in, Slack App, Zapier Integration) and Telecom (Outbound Fax, Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).