Network issues in one of our data centers
Incident Report for FAX.PLUS
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 13:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2021 - 13:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2021 - 12:14 UTC
Investigating
We are currently investigating this issue.
Posted Sep 23, 2021 - 10:02 UTC
This incident affected: Applications (Web App, iOS App, Android App, Email to Fax, G Suite Add-on, Microsoft Word Add-in, Slack App, Zapier Integration).