Service issues in some regions
Incident Report for Fax.Plus
Resolved
We are no longer experiencing issues. This incident has been resolved.
Posted Feb 22, 2021 - 09:47 UTC
Monitoring
Our engineers have deployed a fix to resolve the issue. We will continue to monitor to ensure a full recovery.
Posted Feb 22, 2021 - 09:04 UTC
Investigating
We're experiencing issues in some regions and our engineers are looking into it.
Posted Feb 22, 2021 - 08:53 UTC
This incident affected: Applications (Web App, iOS App, Android App).