Global network infrastucture issues

Incident Report for Fax.Plus

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 12:39 UTC

Identified

We're currently experiencing issues with the global network infrastructure
Posted Nov 18, 2025 - 12:37 UTC
This incident affected: Fax.Plus (Web Application, iOS Application, Android Application, Google Add-on, Microsoft Word Add-in, REST Developer API).