Fax Reception Degradation
Incident Report for FAX.PLUS
Resolved
Our Engineering team has resolved the issue with incoming faxes. Incoming faxes should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jun 30, 2020 - 13:51 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with inbound faxes. We'll continue monitoring the situation, and post an update as soon as the issue is fully resolved.
Posted Jun 30, 2020 - 12:30 UTC
Investigating
Our Engineering team has identified an issue for inbound faxes on some of our numbers.
Posted Jun 30, 2020 - 12:25 UTC
This incident affected: Telecom (Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).