CDN and API connectivity issues on the upstream provider

Incident Report for Fax.Plus

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 05, 2025 - 09:08 UTC
This incident affected: Applications (Web App, iOS App, Android App, Google Add-on, Microsoft Word Add-in, Zapier Integration), Website (Home Page), and Infrastructure (REST API).