Network connectivity issue in one of our data centers
Incident Report for Fax.Plus
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 11:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2022 - 10:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2022 - 09:53 UTC
Investigating
We're experiencing an elevated number of errors in fax transmission in some regions. We are investigating the issue.
Posted Jun 29, 2022 - 08:45 UTC
This incident affected: Telecom (Outbound Fax, Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).