Issue loading FAX.PLUS in some regions
Incident Report for FAX.PLUS
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 13:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 29, 2021 - 11:13 UTC
Update
We are continuing to investigate this issue.
Posted Mar 29, 2021 - 11:12 UTC
Investigating
We are currently investigating this issue.
Posted Mar 29, 2021 - 11:11 UTC
This incident affected: Website (Home Page) and Applications (Web App, iOS App, Android App).