Issues with email delivery
Incident Report for Fax.Plus
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 18:44 UTC
Investigating
We are experiencing issues with our email deliveries, and our team is investigating the issue.
Posted Jan 25, 2022 - 18:13 UTC
This incident affected: Applications (Email to Fax).