Issue with purchasing fax number in some regions

Incident Report for Fax.Plus

Resolved

This incident has been resolved.
Posted Mar 05, 2022 - 02:02 UTC

Update

We are continuing to investigate this issue.
Posted Mar 04, 2022 - 23:02 UTC

Investigating

We are currently investigating this issue.
Posted Mar 04, 2022 - 22:36 UTC
This incident affected: Telecom (Fax Numbers (Purchase and Renewal)).