Issues with fax transmission in some regions

Incident Report for Fax.Plus

Resolved

This incident has been resolved.
Posted May 02, 2022 - 14:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 02, 2022 - 13:47 UTC

Investigating

We're experiencing an elevated number of errors in fax transmission in some regions. We are investigating the issue.
Posted May 02, 2022 - 13:20 UTC
This incident affected: Fax.Plus (Outbound Fax, Inbound Fax (North America), Inbound Fax (Middle East & Africa), Inbound Fax (Europe), Inbound Fax (APAC), Inbound Fax (Latin America)).