Inbound fax issues in some regions
Incident Report for Fax.Plus
Resolved
This incident has been resolved.
Posted Mar 04, 2021 - 18:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2021 - 17:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 04, 2021 - 17:46 UTC
This incident affected: Telecom (Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).