Issues with fax transmission in some regions
Incident Report for Fax.Plus
Resolved
This incident has been resolved.
Posted May 12, 2022 - 21:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2022 - 21:30 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 21:20 UTC
Investigating
We're experiencing an elevated number of errors in fax transmission in some regions. We are investigating the issue.
Posted May 12, 2022 - 21:15 UTC
This incident affected: Telecom (Outbound Fax, Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).