Partial outage for inbound & outbound fax in some regions
Incident Report for Fax.Plus
Resolved
This incident has been resolved.
Posted May 05, 2021 - 11:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 05, 2021 - 10:58 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2021 - 10:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 05, 2021 - 10:19 UTC
This incident affected: Telecom (Outbound Fax, Inbound Fax, North America, Inbound Fax, Middle East & Africa, Inbound Fax, Europe, Inbound Fax, APAC, Inbound Fax, Latin America).